Windows Vista Bug: Standard Gateway auf „Null“ setzen

Zugegeben, es kommt nicht of vor, dass man einen Default Gateway, bzw. den Standard Gateway auf einem Computer ohne entsprechende Werte setzt. Bei diversen Server-Umgebungen und Firewall-Konfigurationen ist dies aber meist unabdingbar – beispielsweise falls eine externe Internetverbindung auf mehrere interne Netzverbindungen gemappt wird. Interne Netzwerkkarten/Verbindungen erhalten dann in der Regel keinen Gateway.

Windows Vista „erfreut“ mit der Eigenart einen solchen Default Gateway einfach selbst zu vergeben, auch wenn die Daten im Kontrollfeld (Netzwerkadapter, Einstellungen. TVP/IP) leer sind. Dies führt zu einer unweigerlichen Fehlfunktion im Netzwerk des Unternehmens. Der Grund dafür ist ein Bug in Windows Vista – scheinbar erst ab Service Pack 2 (SP2), der eventuell vorhandene, ältere Werte nicht zuverlässig aus der Registry des Systems löscht.

Wunsch-Einstellung

Um dies zu lösen hilft der folgende Workaround:

  • Start – „Ausführen“ klicken
  • „regedit“ in die Zeile eintippen und bestätigen
  • Folgenden Key suchen: HKEY_LOCAL_MACHINE/ System/ Current Control Set/ Services/ Tcpip/ Parameters/ Interfaces
  • Das entsprechende Interface auswählen (je nach Konfiguration können die Keys unterschiedlich sein)
  • Im entsprechenden Key den Wert „Default Gateway“ auswählen
  • Vorhandene Werte löschen (nicht „0.0.0.0“) oder nach Belieben neu vergeben
  • Computer neu starten

Dieser Fix führte bei mir zum Erfolg. Hoffe der Tipp erspart anderen unnötige Stunden einer Konfigurations-Fehler Suche.

Über den Autor

Andreas Unterhuber studierte Wirtschatfsinformatik und ist seit 2007 Geschäftsführer der KIM Keep In Mind GmbH mit Sitz in Bozen. Mit seinem Fachwissen in Video Encoding, diverser Programmiersprachen sowie in Datenbanken und Serversystemen unterstützt er zahlreiche nationale und internationale IT Projekte.